Lee

release ApexDC++ 1.5.7 security update

30 posts in this topic

Following DC++'s recent security fixes, we have released 1.5.7 to keep our users protected. In addition to the security fixes we have merged the latest Plugin API code with DC++ so you can use the plugins available on this page. Make sure you update the plugins if you're upgrading from 1.5.6. You can check out the full changelog available here.

 

Developers can now compile our source using Microsoft Visual C++ 2012 as we have provided support for this. Separate Windows XP binaries are compiled with 2012 - make sure you check out the XP folder if you're upgrading on Windows XP. The installer will automatically select the correct binaries if you're unsure.

 

We strongly recommend all existing users upgrade due to the nature of the security fixes.

 

Update 07/08/2013: >An updated version has been uploaded. Everyone who has upgraded before this date will need to download the new version - sorry for any inconvenience. >More information is available here.

 

Download: ApexDC++ 1.5.7

Edited by Lee

Share this post


Link to post
Share on other sites

The upgrade would not work for me. My OS is Win XP Pro SP3 and I had Apex 1.5.6 installed. Upgraded to the latest version but the sofware would not open. After trying to start ApexDC, apexdc.exe process appears briefly in the Windows Task Manager processes list and disappears immediately. Did a clean install too, but the result is the same.

 

What could be the solution?

Share this post


Link to post
Share on other sites

The upgrade would not work for me. My OS is Win XP Pro SP3 and I had Apex 1.5.6 installed. Upgraded to the latest version but the sofware would not open. After trying to start ApexDC, apexdc.exe process appears briefly in the Windows Task Manager processes list and disappears immediately. Did a clean install too, but the result is the same.

 

What could be the solution?

 

Thanks, we're investigating...

Share this post


Link to post
Share on other sites

The upgrade would not work for me. My OS is Win XP Pro SP3 and I had Apex 1.5.6 installed. Upgraded to the latest version but the sofware would not open. After trying to start ApexDC, apexdc.exe process appears briefly in the Windows Task Manager processes list and disappears immediately. Did a clean install too, but the result is the same.

 

What could be the solution?

 

 

Did you upgrade using the binary or the installer, if it was using the installer, could you try using the binary and copying the exe & pdb in the XP folder manually... and see if it runs, just to see whether the issue is with the installer or the actual binaries.

Share this post


Link to post
Share on other sites

For the time being any users running Windows XP/Server 2003 should revert back to 1.5.6 until a fix is in place. We have temporarily disabled the update check during this time.

Share this post


Link to post
Share on other sites

For the time being any users running Windows XP/Server 2003 should revert back to 1.5.6 until a fix is in place. We have temporarily disabled the update check during this time.

ApexDC++ 1.5.7 - There is a problem with the plugins do not work!

Share this post


Link to post
Share on other sites

ApexDC++ 1.5.7 - There is a problem with the plugins do not work!

 

You are using the correct plugins, right? Here is the link. I've also updated the plugin link on the downloads page to point to the correct place, thanks for that. :)

Share this post


Link to post
Share on other sites

MediaPlayers as maintained by us is currently in limbo, because most of the player supports it has have been made obsolete by the advance of time.

 

I will most likely put together a newer version with the still functioning player supports (which at the time of this writing include just Windows Media Player, for most operating systems and player versions) unless better alternatives are made available.

 

No plugins from the linked archive will function with 1.5.7. Besides the media player plugin, alternatives do exist in the repository linked by Lee, as well as few new cool plugins made by the DC++ guys. For the people that missed the memo, the plugins originally introduced in ApexDC 1.0 were always iterated on with the intention of contributing a plugin system to the DC++ project and a while back this happened. Thanks in large part to poy, and the other guys over at DC++, the plugin system is now way more refined and easy to use than it was. For anyone interested in plugin development I suggest checking out the following links.

 

https://launchpad.net/dcpp-plugin-sdk-cpp ( C++ )

https://launchpad.net/dcpp-plugin-sdk-c ( C )

Share this post


Link to post
Share on other sites

Did you upgrade using the binary or the installer, if it was using the installer, could you try using the binary and copying the exe & pdb in the XP folder manually... and see if it runs, just to see whether the issue is with the installer or the actual binaries.

In my first post i was using the installer. Now I tried using the binary amd copying exe & pdb into the extracted folder, but it would not run still.

Share this post


Link to post
Share on other sites

We have now issued a new update to 1.5.7 that fixes startup issues for Windows XP and Server 2003 users on older processors that lacked support for SSE2. Microsoft support for those OSes is due to expire in April 2014 and as such, 2.0.0 will most likely not support Windows XP. Please take this opportunity to upgrade to Windows 7 or 8 before that date.
 
Anybody who has already upgraded to 1.5.7 before the time of this post will need to download the latest version when prompted.

Share this post


Link to post
Share on other sites

hey, i updated to 1.5.7 and the new version opened but the problem is the message of updation is still there  and i cant access my apex dc as i press ok (which is the only option) i am again taken to the dc web page. plz help. my dc shows the new version on top 1.5.7 but plz tell me how to get rid of the update meassage box.

thanks

Share this post


Link to post
Share on other sites

hey, i updated to 1.5.7 and the new version opened but the problem is the message of updation is still there  and i cant access my apex dc as i press ok (which is the only option) i am again taken to the dc web page. plz help. my dc shows the new version on top 1.5.7 but plz tell me how to get rid of the update meassage box.

thanks

 

Please re-download either the Setup or Slim package and try again. There was an issue with some mirrors still offering the older build, which is now blacklisted. You may have been supplied one of those accidentally.

 

Direct link: http://sourceforge.net/projects/apexdc/files/ApexDC%2B%2B/1.5.7/ApexDC%2B%2B_1.5.7_Setup.exe/download

Share this post


Link to post
Share on other sites

So our host had a partial network outage, which we've been suffering from for the last few hours. Here is the response from our host:

 

 

This evening our network supplier on our Databarn datacenter location had a partial network outage. This is mostly a backup location, but our Cloud VPS platform is still running there. We have not received much information from our supplier but the issue has been solved. We are sorry for the inconvenience.

 

To prevent this from happening again our network supplier announced router and network upgrades to be applied quicker than planned. A maintenance schedule for this will be released tomorrow. At YISP we are already building our new Cloud setup in our own network. This should be ready within 1 month +-.

 

Apologies for the inconvenience again - it seems like everything is getting in the way of this release. :)

Share this post


Link to post
Share on other sites

Wow, the size has nearly doubled! The setup for 1.5.6 was around 12.7 MB and for 1.5.7 it is bloated to 23.6 MB. I can see that the bundled XP version is to blame. You guys have already mentioned end of support for XP with 2.0.0, which is probably for the best given Microsoft's end of extended support date is coming up soon. If you are planning any more releases before v2 hits, might I suggest unbundling the XP version and providing it as a separate installer/slim package? That way those of us who moved on from XP years ago won't have to download the extra bits any more. (And yes, before someone says it I guess 23.6 MB is not large relatively speaking, but download caps and slow speeds do cause problems and so a 2x size increase is not something that's aappreciated, especially by people who don't even use XP.)

Share this post


Link to post
Share on other sites

Separate installers is always an option, however, I doubt we will be making several different slim packages... as more possible choices only means more room for mistakenly using the wrong binaries.

 

The difference here being obviously that the installer can tell you if you downloaded the wrong one a file archive can not.

Share this post


Link to post
Share on other sites

ApexDC++_1.5.4_Plugins.7z - For this case the most - especially for MediaPlayers.

as of the past few months I've been handling the MediaPlayer plugin and I admit being on hiatus for that time, so give me a few hours today to fix some issues im having with the builds and I'll try to get a new version of the plugin out tomorrow at the latest :)

Share this post


Link to post
Share on other sites

as of the past few months I've been handling the MediaPlayer plugin and I admit being on hiatus for that time, so give me a few hours today to fix some issues im having with the builds and I'll try to get a new version of the plugin out tomorrow at the latest :)

 

Glad to hear that... I was thinking you had abandoned the thing entirely.

Share this post


Link to post
Share on other sites

Nope just been relaxing in between semesters, we're working on it now, it fully compiles in 32 and 64 bit modules under mingw now and working out some kinks...staying with using WinAPI was meh-tier but it's a whole lot lighter because of it so I'm feeling invigorated again :P

Share this post


Link to post
Share on other sites

I've installed the new update twice and whenever I try clicking on the DC icon on my desktop, it still says update to new version. When i updated the version, it even takes me a page that says I've successfully updated the newest version. Even tried restarting my PC, but the problem persists.

 

Please help at the earliest. I'm using Windows 7

 

 

handythurry likes this

Share this post


Link to post
Share on other sites

I've installed the new update twice and whenever I try clicking on the DC icon on my desktop, it still says update to new version. When i updated the version, it even takes me a page that says I've successfully updated the newest version. Even tried restarting my PC, but the problem persists.

 

Please help at the earliest. I'm using Windows 7

 

Please redownload the installer again. You're using an older mirror/installer that is blacklisted. 

Share this post


Link to post
Share on other sites

I've clicked on the link given by you and downloaded the installer again. But the problem persists.. 

Share this post


Link to post
Share on other sites

I've clicked on the link given by you and downloaded the installer again. But the problem persists.. 

 

It's possible that the mirror you're using has updated itself yet. Try selecting a different mirror rather than it automatically doing it for you. Try this UK mirror for example and let me know how it goes.

Share this post


Link to post
Share on other sites

Hi this updates are.... always when is new version or this error I can use Client even options to move all settings on new version themes... client is closed I can search, join on hubs... I mandatory to update it but this is not ok sometimes I have no time or... and I cant even use DC++ :(

 

Some friends are only for idle on my hub and they not know how to use DC++ in this case I install RSX++ because you can disable search for new version... but on ApexDC++ I could not find these settings...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now