Sign in to follow this  
Followers 0
ifmn

Fix: "An existing connection was forcibly closed by the remote host"

15 posts in this topic

Solving the forcibly closed connection

Statement of problem

Some hubs (Outdated hubs) have problems with the new connection types(NMDC2) and when you connect to such hub you get "An existing connection was forcibly closed by the remote host.", because hubs consider your

$MyInfo for invalid.

NOTE:This is solution only for the outdated hubs problem.You can get the same message for different reasons.

Solution

You must use the old connection types(NMDC1) (and not use emulation for now).To change your current connection type:

  • 1. Go to Settings (General tab).
    2. Select "Connection Type (old DC++ method)" and choose your connection.

Here's an example:

apexcontypejc4.jpg

Share this post


Link to post
Share on other sites

ifmn can you explain why you have to do this please :blushing:

Share this post


Link to post
Share on other sites

Solving the forcibly closed connection

Statement of problem

Some hubs have problems with the new connection types and when you connect to such hub you get "An existing connection was forcibly closed by the remote host."

Solution

You must use the old connection types (and not use emulation for now).To change your current connection type:

  • 1. Go to Settings (General tab).
    2. Select "Connection Type (old DC++ method)" and choose your connection.

Here's an example:

apexcontypejc4.jpg

thats not true, i have it on that setting all the time, yet i still get "An existing connection was forcibly closed by the remote host."

Share this post


Link to post
Share on other sites

Maybe ifmn has solved only one of the reasons, and you have another issue.

Share this post


Link to post
Share on other sites

Maybe ifmn has solved only one of the reasons, and you have another issue.

Yes, my solution is for outdated hubs :

Some hubs have problems with the new connection types and when you connect to such hub you get "An existing connection was forcibly closed by the remote host."

The msg tells you that the hub has disconnected you for some reason(in my guide - for 'invalid' connection type).I dont think you can do anything about the fact that the hub disconnects you.Please try connecting with some other client(or different settings) and if you find solution please post it :) .

Share this post


Link to post
Share on other sites

Note that this error message can also be "legit" (read: plain network problems on the hub side)

Also seeker, if you use DC++ emulation, your old connection type is "converted" to new one so that your connection type wouldn't give you away...

Share this post


Link to post
Share on other sites

Note that this error message can also be "legit" (read: plain network problems on the hub side)

Also seeker, if you use DC++ emulation, your old connection type is "converted" to new one so that your connection type wouldn't give you away...

And that convert can be avoided by emulating some older dc++ version...(as i said)

Share this post


Link to post
Share on other sites

And that convert can be avoided by emulating some older dc++ version...(as i said)

Then there would be a risk of exposure in other areas :)

Share this post


Link to post
Share on other sites

it aint a mess...

Note that this error message can also be "legit" (read: plain network problems on the hub side)

did u try connecting with another client ?!?

Share this post


Link to post
Share on other sites

did u try connecting with another client ?!?

No but i don't need to, as this ain't any special error message specific to DC, but standard socket error message... so it very much can also be legit in some cases. (the text actually comes from windows)

Share this post


Link to post
Share on other sites

No but i don't need to, as this ain't any special error message specific to DC, but standard socket error message... so it very much can also be legit in some cases. (the text actually comes from windows)

I know and i was talking to seeker to prove him i aint creating a mess...

Share this post


Link to post
Share on other sites

I know and i was talking to seeker to prove him i aint creating a mess...

its ok, i didnt say you were.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0