wdc

ApexDC++ freezing, consuming CPU, not responding

2 posts in this topic

Posted (edited)

Hello,

 

on WIndows 10 Home 64 bit, ApexDC++ 1.6.4 (x86-64) i am connecting to more than 85 hubs, it happening that when i start the app and on the Recent hubs tab, i select all hubs and Connect, it waits long time. I restart the ApexDC process as it do not responding. And connect only to like 30 hubs, it works, takes couple of minutes to connect. Then another batch of hubs. Then i come to a stage when ApexDC no longer responds to any actions in the interface and the ApexDC window is not updated. In the process list i see it is eating around 20-50% CPU, I/O delta is changing (in Process Explorer app, but in Task manager, no disk usage), memory too. So it is doing something. I let it running more than 2 hours, but still not started responding to any clicks in the ApexDC interface.

The list of active uploads/downloads is frozen, not updating., list of hub tabs disappeared. This issue appearing repeatedly, seems to be related to some Windows/ApexDC++ limit, because there is like 50% of the CPU left, disk IO free, no bottleneck apparently according to System explorer or Task manager. Yet ApexDC stops responding, it stops responding not just when i try to connect, but suddenly even when i am already connected to all the hubs.

I am letting the computer sleep daily. When i accidentaly clicked Shutdown menu item, Windows terminated process taking care about internet connectivity and some other processes, but the Shutdown not completed as i had many apps opened. But ApexDC started responding as a result, was thinking if some connectivity glitch is not involved in this issue. I am running 3 more file sharing software at same time (Shareaza, qBittorrent, Soulseek).

Edited by wdc

Share this post


Link to post
Share on other sites

I am pretty sure there is no DC client out there (with a graphical user interface) that can handle high volume of hubs very well, of course it depends on hub activity and size as well as any ongoing transfers etc., but the UI's at the very least are not generally built to handle high loads.

The only advice, short of looking at a command line client, I can give is make sure all logging is disabled, although this will only primarily reduce disk I/O.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now