APEX DC didn't launch any more

3 posts in this topic

hello !

I used Apex DC for about 3 or 4 years without ANY sort of problems.. ;-)

TLS is on 

it's a very small community (3 or 10 max people connected) on a private hub 

But  since a few weeks, I can not launch Apex any more... :-( 


I mean : I click, app seams to lauch.. but nothing come... If i clic on the icon of Apex, Windows says : "this app has stoped, would you like to stop it ?"

During this phase : Apex take 50% of CPU of my 4 years old PC... 


My Anti Virus is Kaspersky (payd) : I use others xchange app like uTorrent, Retroshare, Mipony, Grabbit without any problemes ... so what's the pb with Apex ??? :-(


Hope you can help : have you got any idea ?? 


thanxs a lot for your help ;-)





Share this post

Link to post
Share on other sites

What version?

1.5.9 currently has a known issue starting up on some machines. Please try 1.5.8, while this issue will be fixed for next version. If you have a particularly old CPU you may need to use the binaries intended for Windows XP regardless of your version of windows. You can do this by downloading the "slim" binary distribution.

If you are on XP already our installer will use the correct binaries automatically. If you do not have the latest Visual C++ redistributable installed (2013) the installer will also install that for you. Alternatively you may download and install it from Microsoft directly.

Share this post

Link to post
Share on other sites



I just tried a few minutes ago to desinstal 1.5.9 and reinstall 1.5.8 : and it works again :)

I run a 5 years old PC with Win 7


Thanx a lot for your help !! 

have a nice day :)


Share this post

Link to post
Share on other sites