Lee

Released: Welcome to ApexDC 1.4

17 posts in this topic

We are pleased to announce our first featured update since 1.3 was first introduced. We have merged with StrongDC++ 2.42 to keep up with Big Muscle's improvements, introduced a more efficient installer using Inno, rewritten the webserver area that was initially planned for 2.0, and more!

1.4.0 follows StrongDC++'s decision to disable emulation by default on all hubs (please let your hub owners aware of this, otherwise they may be unknowingly blocking ApexDC users). This can be configured under favourite hub properties if you wish. Our new installer detects your system language and processor architecture (32bit or 64bit), has a cleaner uninstall and removes OpenCandy integration in favour of our own ApexDC Toolbar. You will still need to confirm the installation of the ApexDC Toolbar and it can be uninstalled at any time.

The webserver changes mean that you no longer use the templates on apexdc.net and load them locally. There are lots more changes so check out the page for more details.

Let us know what you think!

Download: ApexDC++ 1.4.0

Marthapt and AolemanEl like this

Share this post


Link to post
Share on other sites

Thank you but it looks like there is a serious bug in it (see reports in the forum).

Also, the country flags are old again? Why is this?

Share this post


Link to post
Share on other sites

Yeah, thanks for release but has problems.

About that Toolbar, after I installed it on FF4 beta it froze my tabs, so did a fast removal of that, guess I'll be waiting the full stable release. (btw the freezing of tabs in browser and at the same time apex freezing when tab switching, the problem maybe be similar if not the same in both)

Share this post


Link to post
Share on other sites

Thanks for the release but there seems to be a serious problem with the client 1.4.0 ... It crashes when I change from one hub tab to the other. Please have a look into it B)

Share this post


Link to post
Share on other sites

Yeah, thanks for release but has problems.

About that Toolbar, after I installed it on FF4 beta it froze my tabs, so did a fast removal of that, guess I'll be waiting the full stable release. (btw the freezing of tabs in browser and at the same time apex freezing when tab switching, the problem maybe be similar if not the same in both)

Hi, v1.4 have some problems. When somebody try get my file list, that use one my CPU core on 100% an APEX froze. That happened to all user on my HUB.

Share this post


Link to post
Share on other sites

yep, serious bug.

switching from one connected hub to another (as mentioned before) crashes Apex.

Share this post


Link to post
Share on other sites

We are pleased to announce our first featured update since 1.3 was first introduced. We have merged with StrongDC++ 2.42 to keep up with Big Muscle's improvements, introduced a more efficient installer using Inno, rewritten the webserver area that was initially planned for 2.0, and more!

1.4.0 follows StrongDC++'s decision to disable emulation by default on all hubs (please let your hub owners aware of this, otherwise you may be unknowingly blocking ApexDC users). This can be configured under favourite hub properties if you wish. Our new installer detects your system language and processor architecture (32bit or 64bit), has a cleaner uninstall and removes OpenCandy integration in favour of our own ApexDC Toolbar. You will still need to confirm the installation of the ApexDC Toolbar and it can be uninstalled at any time.

The webserver changes mean that you no longer use the templates on apexdc.net and load them locally. There are lots more changes so check out the page for more details.

Let us know what you think!

Download: ApexDC++ 1.4.0

Seriously. Why do you release such a bad version for the public? The client has some buggs in it.. it crashed 6 times for me.. i've got tired of it so i closed it. And less users can connect to me (download) etc... so i dont see any good point with this version... ill change it back to the old one. and why would it block other apex users to download? u know.. much users will leave apexdc with this version... This has to get better otherwise u'll have less users.

Share this post


Link to post
Share on other sites

Seriously. Why do you release such a bad version for the public? The client has some buggs in it.. it crashed 6 times for me.. i've got tired of it so i closed it.

So it crashed 6 times, why don't you upload the generated exception info for us to look at rather than just say this version is no good.

why would it block other apex users to download? u know.. much users will leave apexdc with this version... This has to get better otherwise u'll have less users.

Where does this come from, 1.4.0 does not block any Apex users (or any other type of users for that matter). If it is about what is written on the news posts that is a note aimed at hub owners not regular users.

Share this post


Link to post
Share on other sites

Where does this come from, 1.4.0 does not block any Apex users (or any other type of users for that matter). If it is about what is written on the news posts that is a note aimed at hub owners not regular users.

I've edited the post to avoid confusion B)

Please post all issues you encounter in the tracker and help us reproduce them.

If you are having frequent crashes/hangs then check out this issue specifically and see if it fixes the problem (it may be because you're running very old country code flags database).

Share this post


Link to post
Share on other sites

Also, the country flags are old again? Why is this?

Could someone explain this? Maybe it has something to do with the GeoIP hang-up we yesterday discovered...

Share this post


Link to post
Share on other sites

Could someone explain this? Maybe it has something to do with the GeoIP hang-up we yesterday discovered...

How old? It'll be because we rewrote the setup script using Inno, but I'm positive I downloaded the latest GeoIP database. If you have a copy of the working GeoIP then by all means send it over. B)

Share this post


Link to post
Share on other sites

No, Lee, I am not talking about the database but about the flags (images displayed in the program) themselves B)

Share this post


Link to post
Share on other sites

No, Lee, I am not talking about the database but about the flags (images displayed in the program) themselves B)

They are old because I didn't bother fixing up the order of the images in the new flags image to reflect the requirements of code merged from SDC. (there are a lot of flags in that file so even locating the ones that would have had to be moved around seemed like a pain, so basically I was lazy and copied the updated version of the old image from SDC).

As for the reason to my laziness, I am completely useless when it comes to anything that has to do with image manipulation. That said we are of course hoping to include the flags from 1.3.9 to this one as soon as possible.

Share this post


Link to post
Share on other sites

I think I know what you are talking about and I would help you with that task B)

Share this post


Link to post
Share on other sites

Hey gang, this has nothing to do with the topic in a sense, but in a way it does .....I just wanted to say thank you to Crise and Lee for getting on that bug yesterday and for all of the help that you both gave....You don't get that kind of service when you pay big bucks for something .

Once again thanks for all the help, the new build is running right along smooth.

Share this post


Link to post
Share on other sites

Hello,

Is there still an version without installer available?

Thanks,

Cent

Share this post


Link to post
Share on other sites

Hello,

Is there still an version without installer available?

Thanks,

Cent

As always. :)

And thanks Old Indain, but a fix is on the way. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now