apexDC++ problem

4 posts in this topic

Hello all,

today i just comed to my work and opened apexDC++ to download some moovies but then he just crashed

Here is the cod

Code: c0000005 (Access violation)

Version: 1.0.1 (2008-03-09)

Major: 5

Minor: 1

Build: 2600

SP: 2

Type: 1

Time: 2008-06-10 07:14:44


d:\development\apexdc\trunk\client\sharemanager.cpp(1004): dcpp::ShareManager::generatePartialList

d:\development\apexdc\trunk\client\uploadmanager.cpp(160): dcpp::UploadManager::prepareFile

d:\development\apexdc\trunk\client\uploadmanager.cpp(439): dcpp::UploadManager::on

d:\development\apexdc\trunk\client\adccommand.h(193): dcpp::CommandHandler<dcpp::UserConnection>::dispatch

d:\development\apexdc\trunk\client\userconnection.cpp(136): dcpp::UserConnection::on

d:\development\apexdc\trunk\client\speaker.h(49): dcpp::Speaker<dcpp::BufferedSocketListener>::fire<dcpp::BufferedSocketListener::X<2>=0x7C839A00,stlp_std::basic_string<char=0x0114FEA4,stlp_std::char_traits<char>=0x01DAFB8C,stlp_std::allocator<char> > >

d:\development\apexdc\trunk\client\bufferedsocket.cpp(248): dcpp::BufferedSocket::threadRead

d:\development\apexdc\trunk\client\bufferedsocket.cpp(520): dcpp::BufferedSocket::checkSocket

d:\development\apexdc\trunk\client\bufferedsocket.cpp(536): dcpp::BufferedSocket::run

d:\development\apexdc\trunk\client\thread.h(164): dcpp::Thread::starter

f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c(348): _callthreadstartex

f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c(326): _threadstartex

kernel32!0x7C80B683: GetModuleFileNameA

Don't know what is wrong.. do i need to reinstal it? OR what?

PS: Pls forgive me that i write this issue here, but i tried to look over on forums and i think this would be the place for bug.. if not.. pls remove where needed and then let a PM to me so i know where to search it.



Share this post

Link to post
Share on other sites

Hello, Please wait for a developer to respond.

Share this post

Link to post
Share on other sites

It may be a download queue problem, tried it with no queue?

Alternatively, try the new 1.1.0 build to see if this is solved.

Share this post

Link to post
Share on other sites

This is fixed, this is the exception info for the remote crash fixed in 1.1.0 if I am not mistaken.

Share this post

Link to post
Share on other sites