Crise

ApexDC++ 1.6.3 maintenance update available

30 posts in this topic

On 29.1.2017 at 10:52 AM, justaguest said:

Plz remove this piece of crap from your site, users are still upgrading to this ****.

Now, is that a nice way to ask someone to do something.

As for people upgrading to this version, as far as I am concerned there is no reason not to, provided they know how to read [the release announcement]. The update check doesn't direct them directly to the download page and, even if it did, the release announcement is linked on both the page they land on as well as the download and the changelog pages. So they have ample oppertunity to read it.

We did our due diligence on the issue after it became known and in the end provided a not one but two working alternative solutions. Whether people make use of those solutions is not something I can enforce in the slightest. Likewise taking 1.6.3 out of circulation, is effectively not possible. Even if I did remove it from the site, the binaries are still out there. Also, having said that there is currently no easy way to roll the website back and then redo the changes when the version with the fix is ready, which is why I will rely on users ability to read and be people who can think for themselves instead.

Now, as far as hub admins go, they have two options, either instruct people not to upgrade to 1.6.3 or point them to the workaround provided. Alternatively they of course could enforce a bans on the use of the client, either version specific or for the client as a whole. However, this again is not something we can influence and as such how they deal with the issue is entirely up to them.

As far as I am concerned, by providing a fixed version at our earliest convenience (which will likely be this weekend, because people have a lives), is all we have to do.

Share this post


Link to post
Share on other sites
On 1/9/2017 at 6:10 AM, Crise said:

It has been quite a while again.

We are pleased to announce the immediate availability of 1.6.3 a maintenance update continuing in the same vein as the two before it. This time the focus is on updating third party dependencies and build tools with the latest security updates and patches. Notably the binaries distributed for the Windows XP operating system had a configuration issue for the previous version and this has now been addressed for our friends still in the past.

A full list of changes are available on here. As usual we strongly recommend upgrading to 1.6.3 as soon as possible, regardless of which version of Windows you happen to be running. For the people who need the XP compatible binaries, we would like to give this remainder about changes introduced in release packaging with the previous version.

Download: ApexDC++ 1.6.3

Update: 1.6.3 has an issue with compressed transfers, that affects connectivity, turning off the setting "Enable safe and compressed transfers" should avoid this issue on 1.6.3. Alternatively you can hold off upgrading until a fix is available.

ApexDC++ 1.6.4 is launched.

Does it means has this error decompression problem is solved.

Please guide.

Regards,

Edited by uchitshah

Share this post


Link to post
Share on other sites

ok so I have 1.6.3. I was told to downgrade my client. cool. now eveytime i open apex  it keeps telling me I have to upgrade to 1.6.4 . nope.    the release notes say it fixes connectivity with older operating systems, I have win 10. I keep getting kicked & banned for an hour everytime.  I posted for help in the support section, no answer yet

Share this post


Link to post
Share on other sites
On 2/11/2017 at 2:41 PM, pneal1965 said:

ok so I have 1.6.3. I was told to downgrade my client. cool. now eveytime i open apex  it keeps telling me I have to upgrade to 1.6.4 . nope.    the release notes say it fixes connectivity with older operating systems, I have win 10. I keep getting kicked & banned for an hour everytime.  I posted for help in the support section, no answer yet

The upgrade notice says it fixes connectivity issues with older versions (of apexdc) ie. the problem with 1.6.3 discussed here.

Hubs should discourage the use of 1.6.3. However, if they are doing the same for .4 then they are in the wrong in the sense that 1.6.4 exist to address the problem with 1.6.3.

As far as we are aware, there is no connectivity issues with 1.6.4, with any version of ApexDC or any client that we are aware of.

You should be able to use version 1.6.4 or 1.6.2 without problems. However, you should not use 1.6.3.

 

On 2/10/2017 at 10:09 PM, uchitshah said:

ApexDC++ 1.6.4 is launched.

Does it means has this error decompression problem is solved.

Please guide.

Regards,

That is exactly what it means, as it says in the 1.6.4 announcement.

Share this post


Link to post
Share on other sites
6 hours ago, Crise said:

The upgrade notice says it fixes connectivity issues with older versions (of apexdc) ie. the problem with 1.6.3 discussed here.

Hubs should discourage the use of 1.6.3. However, if they are doing the same for .4 then they are in the wrong in the sense that 1.6.4 exist to address the problem with 1.6.3.

As far as we are aware, there is no connectivity issues with 1.6.4, with any version of ApexDC or any client that we are aware of.

You should be able to use version 1.6.4 or 1.6.2 without problems. However, you should not use 1.6.3.

 

That is exactly what it means, as it says in the 1.6.4 announcement.

Thank you,

It is quite great of you to solve the problem.

Thanks for all your efforts.

in keeping dc++ up and running and upgrading it from time to time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now